RouterOS FAQ/Häufig gestellte Fragen zu RouterOS

Manual:RouterOS FAQ

Siehe auch: Mikrotik_RouterOS_Preguntas_Frecuentes_(español/spanisch)

Inhalt:

  • 1 Was ist MikroTik RouterOS™?
  • 2 Installation
  • 3 Einloggen und Passwörter
  • 4 Fragen zur Lizenzierung
  • 5 Upgrading
  • 6 Downgrading
  • 7 TCP/IP bezogene Fragen
  • 8 Datentransferraten Management bezogene Fragen
  • 9 Wlan Fragen
  • 10 BGP Fragen

1 Was ist MikroTik RouterOS™?
MikroTik RouterOS™ ist eine Router-Betriebssystem-Software, welches einen normalen Intel PC oder MikroTik RouterBOARD™ Hardware in einen Router verwandelt.
Über welchen Funktionsumfang verfügt RouterOS™?
RouterOS Funktionsumfang
Kann man MikroTiks RouterOS™ Funktionalität testen, bevor man eine Lizenz kauft?
Ja, man kann die Installationsdateien von MikroTik’s Website laden und einen eigenen Mikrotik Router installieren. Der Router verfügt dann für 24Std. über die volle Funktionalität ohne, dass man einen Lizenzschlüssel erwerben muss. Das reicht aus, um den Router z.B an 3 Tage für jeweils 8Std zu testen, wenn man den Router nach jeweils 8Std herunterfährt.
Wo bekommt man einen Lizenzschlüssel?
Man legt einen Account auf MikroTik’s Website an(oben, auf der rechten Seite, auf  www.mikrotik.com). Dort kann man dann mit Kreditkarte einen Schlüssel käuflich erwerben.
Kann man MikroTik Router verwenden, um über einen Provider eine T1, T3, oder andere Highspeed-Anbindung zu nutzen?
Ja, man kann verschiedene, von Mikrotik‘ s RouterOS™ unterstützte NICs installieren und erhält zusammengefasst in einer Box einen Edge router, einen Backbone Router, eine Firewall, einen Datentransferraten-Manager, einen VPN Server, einen Wireless Access Point, einen HotSpot und vieles mehr. Zusätzlich sollte man noch das Specification Sheet und das Manual für unterstützte Interfaces zu Rate ziehen!
Wie schnell wird das sein?
Ein Intel PC ist schneller, als so gut wie jeder proprietäre Router und selbst in einer 100MHz CPU ist ausreichend Rechenkraft vorhanden.
Wie verhält sich die Software im Vergleich zu einem Cisco Router?
Auch bei dieser Software ist so gut wie alles möglich, was auch proprietäre Router zu bieten haben, jedoch zu einem Bruchteil dessen, was diese kosten und gleichzeitiger Flexibilität beim upgraden, Einfachheit des Managements und der Wartung.
Welches Betriebssystem benötigt man, um MikroTik’s RouterOS™ zu installieren?
Es wird kein Betriebssystem benötigt. MikroTik’s RouterOS™ ist ein standalone Operating System. Das OS basiert auf dem Linux Kernel und ist sehr stabil. Die Festplatte wird jedoch beim installieren vollständig überschrieben. Keine zusätzliche Disk-Unterstützung wird angeboten, da nur eine primäre Master HDD oder FlashDisk benötigt wird (eine Ausnahme wäre der WEB Proxy Cache).
Wie sicher ist der Router, wenn er aufgesetzt ist?
Der Zugang zum Router wird über Name und Passwort abgesichert. Zusätzlich können weitere Nutzer hinzugefügt und Rechte für Nutzergruppen gesetzt werden. Remote-Zugriffe auf den Router können auf Nutzer oder IP Adressen beschränkt werden. Über Firewall Filter ist es am einfachsten den Router und das Netzwerk abzusichern.

2 Installation

Wie kann man RouterOS installieren?
RouterOS kann entweder von der CD oder mit Netinstall installiert werden.
Wie groß dürfen die HDDs bei der Nutzung von MikroTik RouterOS™ sein?
MikroTik RouterOS™ unterstützt Festplatten, die größer als 8GB sind (normalerweise bis zu 120GB). Es sollte jedoch sichergestellt werden, dass das BIOS des Motherboards, des Rechners, auf dem der Router läuft, diese Festplattengrößen unterstützt.
Kann man MikroTik RouterOS™ auf jeder Festplatte im eigenen System laufen lassen?
Ja
Gibt es in MikroTik RouterOS™ eine Unterstützung für den Betrieb von mehreren Festplatten?
Ein zweites Laufwerk wird für Web cache unterstützt. Diese Unterstützung wurde in RouterOS v2.8 hinzugefügt, wohingegen ältere RouterOS Versionen nicht mehr als eine Festplatte unterstützen.
Warum stoppt die CD Installation an einem Punkt und geht nicht „den ganzen Weg durch“?
Auf manchen Motherboards funktioniert die CD Installation nicht sauber. Dies sollte mit einem Neustart und einer neuen Installation behoben sein. Wenn nicht, sollte man die Installation mit anderer Hardware ausprobieren.

3 Einloggen und Passwörter

Wie lauten Nutzername und Passwort, wenn man sich auf dem Router das erste Mal einloggt?
Der Nutzername ist immer ‚admin‘ und es gibt kein Passwort (danach drückt man einfach ‚Enter‘). Mit dem ‚/password‘ Kommando kann man das Passwort ändern.
Wie kann man ein vergessenes Passwort wiederherstellen?
Wenn man das Passwort vergisst, gibt es kein zurück und man muss den Router neu installieren.
Nach einem Stromausfall startet der der MikroTik Router nichtmehr
Wenn man den Router nicht heruntergefahren hat, wurde das Dateisystem nicht richtig ausgehangen. Beim starten von RouterOS™ wird ein Dateisystem-Check ausgeführt. Abhängig von der Festplattengröße kann dies einige Minuten in Anspruch nehmen. Diese Prüfung darf nicht unterbrochen werden, da es die Installation unbrauchbar machen würde.
Wie bekommt man Zugriff auf den Router, wenn die LAN Interfaces deaktiviert wurden?
Man kann sich auf den Router entweder lokal (mit Monitor und Tastatur) verbinden oder über die serielle Konsole.

4 Fragen zur Lizenzierung

Wieviele MikroTik RouterOS™ Installations deckt eine Lizenz ab?
Pro RouterOS Installation wird eine Lizenz benötigt. Jeder installierte Router bracht also eine separate Lizenz.
Läuft die Lizenz aus?
Die Lizenz läuft niemals aus. Der Router läuft damit für immer. Die einzige Begrenzung liegt in der Version, auf welche ein Upgrade erfolgen kann. Wenn z.B. angegeben ist „Upgradable to v4.x“ bedeutet dies, dass man alle RouterOS v4 Releases aufspielen kann, aber nicht v5. Dies bedeutet nicht, dass man nicht solange man möchte, auf der v4 verbleiben kann.
// Hinweis von Mikrotik-Blog.de: das ist unserer Wissens nach mit den neuesten RouterOS-Versionen inzwischen hinfällig.
Wie kann man die MikroTik RouterOS™ Software neu installieren, ohne die Software Lizenz zu verlieren?
Man muss mit Hilfe von CD, Floppies oder Netinstall die Neuinstallation von MikroTik RouterOS™ auf der HDD vornehmen und darauf achten, das die vorige Installation noch intakt ist. Die Lizenz ist auf die HDD bezogen, weswegen man diese weder formatieren, noch partitionieren sollte, da dies den Schlüssel löscht. Für die Neuinstallation nutzt man dieselben BIOS Einstellungen für die HDD, wie bei der vorigen Installation!
Kann man die MikroTik RouterOS™ Software Lizenz auf einer anderen Hardware nutzen?
Ja, man kann andere Hardware nutzen (anderes Motherboard oder andere NICs), muss aber darauf achten, dieselbe HDD zu nutzen, da die Lizenz auf die HDD bezogen ist (solange man diese nicht formatiert oder man fdisk Dienste einsetzt). Eine Neuinstallation ist nicht nötig, wenn man andere Hardware nutzt. Wenn man für die Lizenz bezahlt, sollte man sich im klaren darüber sein, dass diese Lizenz nicht auf einer anderen HDD genutzt werden kann, außer auf derjenigen, auf der diese installiert wurde.
Der Lizenz-Transfer auf eine andere Festplatte kostet 10$ und kann über den Support arrangiert werden.
Was kann man machen, wenn die Festplatte, auf welcher MikroTik RouterOS™ installiert wurde zerstört wird und man eine neue installieren muss?
Wenn man für die Lizenz bezahlt hat, kann man eine Mail an support[at]mikrotik.com senden und die Situation beschreiben. Mikrotik verlangt ggf. die Einsendung der zerstörten Hardware um diese zu prüfen, um dann ggf. einen Ersatzschlüssel auszustellen.
Was passiert, wenn diese erneut zerstört wird und man den Ersatzschlüssel verliert?
Derselbe Vorgang wie in der Frage zuvor wird ablaufen, mit dem Unterschied, das in diesem Fall die Einsendung der zerstörten Hardware zwingend erforderlich ist.
Wenn man über eine freie Demo Lizenz verfügt, wird kein Ersatzschlüssel ausgestellt. Hier besorgt man sich einfach nochmals eine neue Demo Lizenz oder erwirbt eine Basislizenz.
Weitere Informationen sind hier verfügbar All_about_licenses
Wie gibt man einen neuen Software Key ein?
Eingabe des Schlüssels über Konsole/FTP:
  • Man importiert die angehangene Datei mit dem Kommando ‚/system license import‘ (man sollte diese Datei auf den FTP-Server des Routers hochladen)
Eingabe des Schlüssels über Konsole/Telnet::

  • Man nutzt copy/paste um den Schlüssel im Telnet Fenster einzugeben (egal, in welchem Untermenü). Hier ist darauf zu achten, den kompletten Schlüssel zu kopieren, inkl. der folgenden Zeilen „–BEGIN MIKROTIK SOFTWARE KEY–“ and „–END MIKROTIK SOFTWARE KEY–„
Eingabe des Schlüssels in der Winbox:

  • Über das ’system -> license‘ Menü, in der Winbox, kann man den Schlüssel ‚pasten‘ oder importieren.
Wie man man eine Korrektur vornehmen, wenn man beim Erwerb die Software ID falsch eingegeben hat?
Auf dem Account Server wählt man `work with keys` aus, wählt den falsch eingegebenen Schlüssel aus und klickt auf `fix key`.
Um mehr über die Schlüssel-Eingabe zu erfahren, geht man auf diese Seite
Eingabe eines RouterOS Lizenz-Schlüssels
Alle anderen Informationen, über Lizenz-Schlüssel, sind hier zu finden
All_about_licenses

5 Upgrading

Wie kann man zusätzliche Pakete, mit zusätzlichen Funktionen installieren?
Man muss hier dieselbe Paket-Datei Versionen auswählen (Mit der .npk-Erweiterung) auf der auch das System-Paket basiert. Über das /system package print Kommando kann man sich eine Liste mit allen, installierten Paketen anzeigen lassen. Den freien Platz auf der Festplatte des Routers prüft man mit dem /system resource print Kommando, bevor man weitere Pakete hochlädt. Sicherzustellen ist, dass man noch mindestens 2MB freien Speicher auf dem Router übrig hat, nachdem man neue Pakete hochgeladen hat!
Man lädt die Dateien mit dem ftp BINARY Modus auf den Router und fährt den Router mit dem /system reboot Kommando herunter und führt damit automatisch einen Neustart durch. Die Pakete werden installiert (das Upgrade wird durchgeführt) während der Router herunterfährt. Dies kann man sich auf dem mit dem Router verbundenen Monitor anzeigen lassen. Nach dem Neustart werden einem die installierten Pakete mit dem /system package print Befehl aufgelistet.
Wie kann man Upgraden?
Um ein Software-Upgrade durchzuführen muss man zuerst die aktuellsten Paket-Dateien herunterladen (*.npk) von Mikrotik.com herunterladen (also das ’system‘ und die zusätzlich benötigten Paket-Dateien). Dann verbindet man sich via FTP und lädt die Pakete über den binary Transfer-Modus auf den Router.
Danach startet man den Router mit dem /system reboot Kommando neu. Mehr Informationen gibt es hier: Upgrading_RouterOS
Nach der Installation von zusätzlichen Funktions-Paketen erscheint das relevante Interface nichtmehr in der /interface print Liste.
Man muss das benötigte Lizenz-Level erwerben oder die erforderlichen NPK Pakete installieren (z.B. das ‚wireless‘ Paket).
Wenn man ein RouterOS Upgrade durchführt, wird dabei die Konfiguration zurückgesetzt?
Nein, die Konfiguration bleibt intakt, wenn man ein Upgrade innerhalb der Version durchführt. Wenn man eine Versions-Stufe wechselt (z.B von V2.5 auf V2.6) kann man die die Einstellungen von manchen Funktionen verlieren, wenn es dabei größere Anpassungen von RouterOS gab. Dem kann man vorbeugen, wenn man bei dem Upgrade zuerst auf die letzte Version (z.B. auf die letzte V2.4-Version) geht und dann erst auf die nächsthöhere Version wechselt.
Wieviel freien Speicherplatz braucht man, wenn man ein Upgrade auf eine höhere Version durchführt?
Man benötigt Speicherplatz für die System- und die zusätzlichen Pakete, für die man ein Upgrade durchführen will. Nach dem hochladen der neueren Versions-Pakete, auf den Router, sollten mindestens noch 2MB freier Speicherplatz vorhanden sein. Wenn nicht, sollte man kein Upgrade durchführen! In diesem Fall sollte man zuerst unbenötigte Pakete zuerst deinstallieren und dann erst das Upgrade durchführen.

6 Downgrading

Wie kann man eine MikroTik RouterOS™ Installation auf eine ältere Version downgraden?
Man kann RouterOS™ von jedem Medium mit einer Reinstallation downgraden. Die Software Lizenz verbleibt hierbei auf der HDD, solange die Festplatte nicht partitioniert oder formatiert wird. Die Konfiguration geht hierbei verloren (Man kann die alte Konfiguration natürlich vorab sichern, die Downgrade Option wird jedoch nicht empfohlen, da hierbei unvorhersehbare Ergebnisse hervorgerufen werden können).
Ein anderer weg ist das /system package downgrade Kommando, solange man nicht ein Downgrade auf V2.7.20 oder niedriger durchführt. Man lädt die älteren Pakete via FTP auf den Router und nutzt dann das /system package downgrade Kommando.

7 TCP/IP bezogene Fragen

Man hat zwei NIC-Karten im MikroTik Router aktiv, welche auch wie gewünscht funktionieren und man kann vom Router aus beide Netzwerke anpingen. Was jedoch nicht möglich ist, ist, dass man von einem Netzwerk, durch den Router, das andere Netzwerk oder einen Host im Internet anpingen kann. Eine Firewall ist nicht aktiv.
Dieses typische Probleme zeigt auf, dass man kein Internet Gateway im Routing eingetragen hat. Immer, wenn man ein neues Netzwerk aufsetzt, muss man auch das neue Gateway (z.B. des ISP) angeben. Eine Route muss für das neue Netzwerk angegeben werden. Alternativ kann man sein eigenes Netzwerk auch „verstecken“, wenn man es maskiert, um Zugang zum Internet zu erhalten. Hier sollte man genauestens das Basis Setup durcharbeiten, da in diesem dieses Problem beschrieben und die Lösung aufgezeigt wird.
Im folgenden Beispiel wird die Maskierung des privaten LAN aufgezeigt:
[admin@MikroTik] ip firewall nat> add chain=srcnat action=masquerade out-interface=Public
[admin@MikroTik] ip firewall nat> print
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=Public action=masquerade 
Wie kann man die TCP Port-Nummer für Telnet und HTTP Dienste geändert werden, wenn man nicht unbedingt die Ports 23 und 80 nutzen will?
Die angegebenen Ports kann man unter /ip service ändern.
Wenn man die IP Adresse/Maske in der Form 10.1.1.17/24 für das Filtern oder für queuing Regeln nutz, funktionieren diese nicht.
Die Regeln ‚funktionieren nicht‘ da diese aufgrund der nicht korrekt angegebenen Adresse/Maske zu den Paketen passen. Die richtige Form sähe wie folgt aus:
   10.1.1.0/24 for the IP addresses in the range 10.1.1.0-10.1.1.255, or,
   10.1.1.17/32 for just one IP address 10.1.1.17. 
Es muss ein DHCP-Client eingestellt werden, es gibt aber kein ‚/ip dhcp-client‘ Menü.
Die DHCP Funktion ist nicht im Systen Software Paket enthalten, weshalb man das DHCP-Paket extra installieren muss. Man lädt dieses auf den Router und startet diesen neu.
Kann man IPs statisch an MAC-Adressen via DHCP binden?
Ja, man kann statische Lease zum DHCP-Server-Leases-Liste hinzufügen. DHCP ist allerding standardmäßig unsicher und es wäre sicherer, wenn man die User Authentifizierung und IP-Adressen-Vergabe über PPPoE durchführt. Darüber kann man den Nutzer auch auffordern, sich von einer festgelegten MAC-Adresse aus anzumelden.
Wie kann man zwei verschiedene Subnetze maskieren, indem man zwei verschiedene, extern IP Adressen dafür nutzt?
Man nutzt hier /ip firewall nat mit chain=srcnat action=nat, und gibt in  to-src-address die entsprechenden Werte an. Dieser sollte dann eine der externen Adressen des Routers sein. Wenn man action=masquerade nutzt wird to-src-address aussenvorgelassen, da diese automatisch von der externen Router-Adresse ersetzt wird.
Es ist nicht möglich, via PPPoE manche Websites anzusurfen.
In /ip firewall mangle wechselt man die MSS (maximum segment size) auf 40 bytes weniger, als die Verbindungs-MTU. Beispielsweise setzt man die mangle rule bei einem verschlüsselten PPPoE-Link mit MTU=1492 wie folgt:
 / ip firewall mangle 
 add chain=forward protocol=tcp tcp-flags=syn action=change-mss tcp-mss=!0-1448 new-mss=1448

8 Datentransferraten Management bezogene Fragen

wie kann man die Datentransferrate im Bridge Modus kontrollieren (bandwidth shaping)?
In den bridge settings aktiviert man use-ip-firewall.
Kann ich MikroTik als Bridge and einen traffic shaper in einer Maschine nutzen?
Ja, man kann alle, umfangreichen queue management Funktionen nutzen. Man setzt die queue auf das Interface, über welches der Traffic den Router verlässt, wenn er den Router passiert. Dies ist nicht das Bridge-Interface! Die queue auf dem Bridge-Interface bezieht sich nur auf den Traffic, der vom Router verursacht wird.
Kann man Datentransferraten basierend auf der MAC-Adresse limitieren?
Für den Download:
   1. connection-mark all packets from the MAC of each client with different marks
   for each client using action=passthrough:
   /ip firewall mangle add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-connection new-connection-mark=host11 passthrough=yes
   2. Remark these packets with flow-mark (again different flow-marks for each connection-marks):
   /ip firewall mangle add chain=prerouting connection-mark=host11 new-packet-mark=host11
   3. We can use these flow-marks in queue trees now.
Während diese Lösung funktionieren sollte, ist sie grundsätzlich fehlerhaft, da das erste Paket jeder für diese Clients bestimmten Verbindung, nicht berücksichtigt wird.
Für den Upload:
   [admin@AP] ip firewall mangle> add chain=prerouting src-mac-address=11:11:11:11:11:11 \
   action=mark-packet new-packet-mark=upload

9 Wlan Fragen

Kann man das Wlan Interface bridgen, während man sich im station mode befindet?
Nein, das ist nicht möglich.

Siehe auch >>

10 BGP Fragen

Siehe auch BGP FAQ und HowTo

 

[ Top | Back to Content ]

Dieser Beitrag wurde unter RouterOS FAQ abgelegt und mit , , , , , , , , , , , , , , , , , , , , , , , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.